Maverick Legacy Client 1.6.22 Released

Features

  • Options added to Ssh2Context that allow disabling of ETM (encrypt-then-mac) and non standard algorithms such as @openssh.com and @ssh.com algorithm implementations.

Bug Fixes

  • PuTTY private key file should use AES CBC cipher directly and not use supported ciphers ComponentFactory.*
  • Key derivation function creates incompatible key when key exchange hash function output is smaller than required key.
  • Remote identification without additional software version causes connection exception.

IMPORTANT NOTICE: This version requires maverick-common 1.1.9 and cannot be used with earlier versions of maverick-common jar file.

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.